p PatchFirst

CVE-2012-4885

CVE-2012-4885

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The wikitext parser in MediaWiki 1.17.x before 1.17.3 and 1.18.x before 1.18.2 allows remote attackers to cause a denial of service (infinite loop) via certain input, as demonstrated by the padleft function.

EPSS 1.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • mediawiki Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:1.19.0-1

    Update to 1:1.19.0-1

  • mediawiki Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:1.19.0-1

    Update to 1:1.19.0-1

  • mediawiki Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:1.19.0-1

    Update to 1:1.19.0-1

Original sources

Check your server →