CVE-2012-6099
CVE-2012-6099
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The moodle1 backup converter in backup/converter/moodle1/lib.php in Moodle 2.1.x before 2.1.10, 2.2.x before 2.2.7, 2.3.x before 2.3.4, and 2.4.x before 2.4.1 does not properly validate pathnames, which allows remote authenticated users to read arbitrary files by leveraging the backup-restoration feature.
EPSS 1.1% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
moodle/moodle Packagist
- Versions
- 2.4
- v2.4.0
- v2.4.0-rc1
- Affected ranges
- ECOSYSTEM: ≥ 2.4, < 2.4.1
Update to 2.4.1
moodle/moodle Packagist
- Affected ranges
- ECOSYSTEM: ≥ 2.3, < 2.3.4
Update to 2.3.4
moodle/moodle Packagist
- Affected ranges
- ECOSYSTEM: ≥ 2.2, < 2.2.7
Update to 2.2.7
moodle/moodle Packagist
- Affected ranges
- ECOSYSTEM: ≥ 2.1, < 2.1.10
Update to 2.1.10