CVE-2012-6130
CVE-2012-6130
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Cross-site scripting (XSS) vulnerability in the history display in Roundup before 1.4.20 allows remote attackers to inject arbitrary web script or HTML via a username, related to generating a link.
CVSS 5.3 · Medium · EPSS 2.0% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
roundup PyPI
- Versions
- 0.5.9
- 0.6.11
- 0.6.8
- 0.6.9
- 0.7.0
- 0.7.0b3
- 0.7.1
- 0.7.11
- 0.7.12
- 0.7.2
- 0.7.3
- 0.7.4
- 0.7.5
- 0.7.7
- 0.7.8
- 0.7.9
- 0.8.0
- 0.8.0b1
- 0.8.1
- 0.8.2
- 0.8.3
- 0.8.4
- 0.8.5
- 0.8.6
- 0.9.0b1
- 1.0
- 1.0.1
- 1.1.0
- 1.1.1
- 1.1.2
- 1.2.0
- 1.2.1
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.4.0
- 1.4.1
- 1.4.10
- 1.4.11
- 1.4.12
- 1.4.13
- 1.4.14
- 1.4.15
- 1.4.16
- 1.4.17
- 1.4.18
- 1.4.19
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5.1
- 1.4.6
- 1.4.7
- 1.4.8
- 1.4.9
- Affected ranges
- ECOSYSTEM: < 1.4.20
Update to 1.4.20
Original sources
- https://bugzilla.redhat.com/show_bug.cgi?id=722672
- https://pypi.python.org/pypi/roundup/1.4.20
- http://www.openwall.com/lists/oss-security/2012/11/10/2
- http://issues.roundup-tracker.org/issue2550684
- http://www.openwall.com/lists/oss-security/2013/02/13/8
- https://exchange.xforce.ibmcloud.com/vulnerabilities/84189
- https://nvd.nist.gov/vuln/detail/CVE-2012-6130