CVE-2012-6707
CVE-2012-6707
This page contains facts from public vulnerability sources. Check the original advisory before updating.
WordPress through 4.8.2 uses a weak MD5-based password hashing algorithm, which makes it easier for attackers to determine cleartext values by leveraging access to the hash values. NOTE: the approach to changing this may not be fully compatible with certain use cases, such as migration of a WordPress site from a web host that uses a recent PHP version to a different web host that uses PHP 5.2. These use cases are plausible (but very unlikely) based on statistics showing widespread deployment of WordPress with obsolete PHP versions.
CVSS 7.5 · High · EPSS 1.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wordpress Debian:12
- Versions
- 6.1.1+dfsg1-1
- 6.1.6+dfsg1-0+deb12u1
- 6.1.9+dfsg1-0+deb12u1
- 6.2+dfsg1-1
- 6.2.1+dfsg1-1
- 6.2.2+dfsg1-1
- 6.3+dfsg1-1
- 6.3.1+dfsg1-1
- 6.3.2+dfsg1-1
- 6.4.1+dfsg1-1
- 6.4.1+dfsg1-1.1
- 6.4.2+dfsg1-1
- 6.4.3+dfsg1-1
- 6.5+dfsg1-1
- 6.5.2+dfsg1-1
- 6.5.3+dfsg1-1
- 6.5.5+dfsg1-1
- 6.6.1+dfsg1-1
- 6.7.2+dfsg1-1
- 6.7.2+dfsg1-1.1
- 6.8.1+dfsg1-1
- 6.8.3+dfsg1-1
- 6.9+dfsg1-1
- 6.9.4+dfsg1-1
- 7.0+dfsg1-1
- 7.0.2+dfsg1-1
- 7.0.3+dfsg1-1
- 7.1+dfsg1-1
- 7.1.1+dfsg1-1
- 7.1.2+dfsg1-1
- 7.1.3+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Debian:13
- Affected ranges
- ECOSYSTEM: < 6.8.1+dfsg1-1
Update to 6.8.1+dfsg1-1
wordpress Debian:14
- Affected ranges
- ECOSYSTEM: < 6.8.1+dfsg1-1
Update to 6.8.1+dfsg1-1
wordpress Ubuntu:16.04:LTS
- Versions
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published