p PatchFirst

CVE-2013-0170

CVE-2013-0170

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Use-after-free vulnerability in the virNetMessageFree function in rpc/virnetserverclient.c in libvirt 1.0.x before 1.0.2, 0.10.2 before 0.10.2.3, 0.9.11 before 0.9.11.9, and 0.9.6 before 0.9.6.4 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code by triggering certain errors during an RPC connection, which causes a message to be freed without being removed from the message queue.

EPSS 5.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libvirt Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.9.12-6

    Update to 0.9.12-6

  • libvirt Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.9.12-6

    Update to 0.9.12-6

  • libvirt Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.9.12-6

    Update to 0.9.12-6

Original sources

Check your server →