p PatchFirst

CVE-2013-0233

CVE-2013-0233

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Devise gem 2.2.x before 2.2.3, 2.1.x before 2.1.3, 2.0.x before 2.0.5, and 1.5.x before 1.5.4 for Ruby, when using certain databases, does not properly perform type conversion when performing database queries, which might allow remote attackers to cause incorrect results to be returned and bypass security checks via unknown vectors, as demonstrated by resetting passwords of arbitrary accounts.

EPSS 14.1% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ruby-devise Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.4.1-1

    Update to 3.4.1-1

Original sources

Check your server →