CVE-2013-1629
CVE-2013-1629
This page contains facts from public vulnerability sources. Check the original advisory before updating.
pip before 1.3 uses HTTP to retrieve packages from the PyPI repository, and does not perform integrity checks on package contents, which allows man-in-the-middle attackers to execute arbitrary code via a crafted response to a "pip install" operation.
CVSS 8.6 · High · EPSS 6.2% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
python-pip Debian:12
- Affected ranges
- ECOSYSTEM: < 1.3.1-1
Update to 1.3.1-1
python-pip Debian:13
- Affected ranges
- ECOSYSTEM: < 1.3.1-1
Update to 1.3.1-1
python-pip Debian:14
- Affected ranges
- ECOSYSTEM: < 1.3.1-1
Update to 1.3.1-1
python-virtualenv Debian:12
- Affected ranges
- ECOSYSTEM: < 1.9.1-1
Update to 1.9.1-1
python-virtualenv Debian:13
- Affected ranges
- ECOSYSTEM: < 1.9.1-1
Update to 1.9.1-1
python-virtualenv Debian:14
- Affected ranges
- ECOSYSTEM: < 1.9.1-1
Update to 1.9.1-1
pip PyPI
- Versions
- 0.2
- 0.2.1
- 0.3
- 0.3.1
- 0.4
- 0.5
- 0.5.1
- 0.6
- 0.6.1
- 0.6.2
- 0.6.3
- 0.7
- 0.7.1
- 0.7.2
- 0.8
- 0.8.1
- 0.8.2
- 0.8.3
- 1.0
- 1.0.1
- 1.0.2
- 1.1
- 1.2
- 1.2.1
- Affected ranges
- ECOSYSTEM: < 1.3
Update to 1.3
Original sources
- http://www.pip-installer.org/en/latest/installing.html
- https://github.com/pypa/pip/issues/425
- http://www.pip-installer.org/en/latest/news.html#changelog
- https://github.com/pypa/pip/pull/791/files
- https://bugzilla.redhat.com/show_bug.cgi?id=968059
- http://www.reddit.com/r/Python/comments/17rfh7/warning_dont_use_pip_in_an_untrusted_network_a/
- https://nvd.nist.gov/vuln/detail/CVE-2013-1629