p PatchFirst

CVE-2013-1834

CVE-2013-1834

This page contains facts from public vulnerability sources. Check the original advisory before updating.

notes/edit.php in Moodle 1.9.x through 1.9.19, 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allows remote authenticated users to reassign notes via a modified (1) userid or (2) courseid field.

EPSS 1.7% · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • moodle/moodle Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 1.9.0, < 2.2.8

    Update to 2.2.8

  • moodle/moodle Packagist

    Versions
    • v2.3.4
    Affected ranges
    • ECOSYSTEM: ≥ 2.3.0, < 2.3.5

    Update to 2.3.5

  • moodle/moodle Packagist

    Versions
    • v2.4.0
    • v2.4.1
    Affected ranges
    • ECOSYSTEM: ≥ 2.4.0, < 2.4.2

    Update to 2.4.2

  • moodle Ubuntu:Pro:16.04:LTS

    Versions
    • 2.7.9+dfsg-1
    • 2.7.10+dfsg-1
    • 2.7.11+dfsg-1
    • 2.7.11+dfsg-2
    • 2.7.12+dfsg-1
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • moodle Ubuntu:Pro:18.04:LTS

    Versions
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →