p PatchFirst

CVE-2013-1912

CVE-2013-1912

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Buffer overflow in HAProxy 1.4 through 1.4.22 and 1.5-dev through 1.5-dev17, when HTTP keep-alive is enabled, using HTTP keywords in TCP inspection rules, and running with rewrite rules that appends to requests, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via crafted pipelined HTTP requests that prevent request realignment from occurring.

EPSS 5.6% · Fix available

Published
Updated

Stack: system · web

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • haproxy Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.4.23-1

    Update to 1.4.23-1

  • haproxy Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.4.23-1

    Update to 1.4.23-1

  • haproxy Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.4.23-1

    Update to 1.4.23-1

Original sources

Check your server →