CVE-2013-2081
CVE-2013-2081
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not consider "don't send" attributes during hub registration, which allows remote hubs to obtain sensitive site information by reading form data.
EPSS 1.5% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
moodle/moodle Packagist
- Affected ranges
- ECOSYSTEM: < 2.2.10
Update to 2.2.10
moodle/moodle Packagist
- Versions
- v2.3.4
- v2.3.5
- v2.3.6
- Affected ranges
- ECOSYSTEM: ≥ 2.3.0, < 2.3.7
Update to 2.3.7
moodle/moodle Packagist
- Versions
- v2.4.0
- v2.4.1
- v2.4.2
- v2.4.3
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.4.4
Update to 2.4.4
moodle Ubuntu:Pro:16.04:LTS
- Versions
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
moodle Ubuntu:Pro:18.04:LTS
- Versions
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-37822
- https://moodle.org/mod/forum/discuss.php?d=228933
- http://lists.fedoraproject.org/pipermail/package-announce/2013-May/106965.html
- http://openwall.com/lists/oss-security/2013/05/21/1
- http://lists.fedoraproject.org/pipermail/package-announce/2013-May/107026.html
- http://lists.fedoraproject.org/pipermail/package-announce/2013-May/106988.html
- https://nvd.nist.gov/vuln/detail/CVE-2013-2081