p PatchFirst

CVE-2013-4303

CVE-2013-4303

This page contains facts from public vulnerability sources. Check the original advisory before updating.

includes/libs/IEUrlExtension.php in the MediaWiki API in MediaWiki 1.19.x before 1.19.8, 1.20.x before 1.20.7, and 1.21.x before 1.21.2 does not properly detect extensions when there are an even number of "." (period) characters in a string, which allows remote attackers to conduct cross-site scripting (XSS) attacks via the siprop parameter in a query action to wiki/api.php.

CVSS 6.1 · Medium · EPSS 1.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • mediawiki

    Versions
    • 1.19.x before 1.19.8: Affected
    • 1.20.x before 1.20.7: Affected
    • and 1.21.x before 1.21.2: Affected

    No fix published

  • mediawiki Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:1.19.8+dfsg-1

    Update to 1:1.19.8+dfsg-1

  • mediawiki Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:1.19.8+dfsg-1

    Update to 1:1.19.8+dfsg-1

  • mediawiki Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:1.19.8+dfsg-1

    Update to 1:1.19.8+dfsg-1

Original sources

Check your server →