p PatchFirst

CVE-2013-4363

CVE-2013-4363

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Algorithmic complexity vulnerability in Gem::Version::ANCHORED_VERSION_PATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.2, 1.8.24 through 1.8.26, 2.0.x before 2.0.10, and 2.1.x before 2.1.5, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression. NOTE: this issue is due to an incomplete fix for CVE-2013-4287.

EPSS 1.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rubygems Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.2.0~rc.1-1

    Update to 3.2.0~rc.1-1

  • rubygems Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.2.0~rc.1-1

    Update to 3.2.0~rc.1-1

  • rubygems Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.2.0~rc.1-1

    Update to 3.2.0~rc.1-1

Original sources

Check your server →