CVE-2013-4540
CVE-2013-4540
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Buffer overflow in scoop_gpio_handler_update in QEMU before 1.7.2 might allow remote attackers to execute arbitrary code via a large (1) prev_level, (2) gpio_level, or (3) gpio_dir value in a savevm image.
EPSS 4.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
qemu Debian:12
- Affected ranges
- ECOSYSTEM: < 2.1+dfsg-1
Update to 2.1+dfsg-1
qemu Debian:13
- Affected ranges
- ECOSYSTEM: < 2.1+dfsg-1
Update to 2.1+dfsg-1
qemu Debian:14
- Affected ranges
- ECOSYSTEM: < 2.1+dfsg-1
Update to 2.1+dfsg-1
qemu Ubuntu:14.04:LTS
- Versions
- 1.5.0+dfsg-3ubuntu5
- 1.5.0+dfsg-3ubuntu6
- 1.6.0+dfsg-2ubuntu1
- 1.6.0+dfsg-2ubuntu2
- 1.6.0+dfsg-2ubuntu3
- 1.6.0+dfsg-2ubuntu4
- 1.7.0+dfsg-2ubuntu1
- 1.7.0+dfsg-2ubuntu2
- 1.7.0+dfsg-2ubuntu3
- 1.7.0+dfsg-2ubuntu4
- 1.7.0+dfsg-2ubuntu5
- 1.7.0+dfsg-2ubuntu7
- 1.7.0+dfsg-2ubuntu8
- 1.7.0+dfsg-2ubuntu9
- 1.7.0+dfsg-3ubuntu1~ppa1
- 1.7.0+dfsg-3ubuntu1
- 1.7.0+dfsg-3ubuntu2
- 1.7.0+dfsg-3ubuntu3
- 1.7.0+dfsg-3ubuntu4
- 1.7.0+dfsg-3ubuntu5
- 1.7.0+dfsg-3ubuntu6
- 1.7.0+dfsg-3ubuntu7
- 2.0.0~rc1+dfsg-0ubuntu1
- 2.0.0~rc1+dfsg-0ubuntu2
- 2.0.0~rc1+dfsg-0ubuntu3
- 2.0.0~rc1+dfsg-0ubuntu3.1
- 2.0.0+dfsg-2ubuntu1
- 2.0.0+dfsg-2ubuntu1.1
- 2.0.0+dfsg-2ubuntu1.2
- Affected ranges
- ECOSYSTEM: < 2.0.0+dfsg-2ubuntu1.3
Update to 2.0.0+dfsg-2ubuntu1.3
Original sources
- http://lists.opensuse.org/opensuse-security-announce/2014-10/msg00003.html
- http://lists.nongnu.org/archive/html/qemu-stable/2014-07/msg00187.html
- http://lists.opensuse.org/opensuse-security-announce/2014-10/msg00002.html
- http://lists.gnu.org/archive/html/qemu-devel/2013-12/msg00394.html
- http://lists.fedoraproject.org/pipermail/package-announce/2014-May/133345.html
- http://git.qemu.org/?p=qemu.git%3Ba=commit%3Bh=52f91c3723932f8340fe36c8ec8b18a757c37b2b
- https://nvd.nist.gov/vuln/detail/CVE-2013-4540