CVE-2013-4940
CVE-2013-4940
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Cross-site scripting (XSS) vulnerability in io.swf in the IO Utility component in Yahoo! YUI 3.10.2, as used in Moodle through 2.1.10, 2.2.x before 2.2.11, 2.3.x before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.1, and other products, allows remote attackers to inject arbitrary web script or HTML via a crafted string in a URL. NOTE: this vulnerability exists because of a CVE-2013-4939 regression.
CVSS 5.3 · Medium · EPSS 1.5% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
yui npm
- Affected ranges
- SEMVER: ≥ 3.0.0, < 3.10.11
Update to 3.10.11
yui npm
- Versions
- 3.10.12
- Affected ranges
- SEMVER: ≥ 3.10.12, < 3.10.13
Update to 3.10.13
moodle/moodle Packagist
- Affected ranges
- ECOSYSTEM: < 2.2.11
Update to 2.2.11
moodle/moodle Packagist
- Versions
- v2.3.4
- v2.3.5
- v2.3.6
- v2.3.7
- Affected ranges
- ECOSYSTEM: ≥ 2.3.0, < 2.3.8
Update to 2.3.8
moodle/moodle Packagist
- Versions
- v2.4.0
- v2.4.0-rc1
- v2.4.1
- v2.4.2
- v2.4.3
- v2.4.4
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0-rc1, < 2.4.5
Update to 2.4.5
moodle/moodle Packagist
- Versions
- v2.5.0
- v2.5.0-beta
- v2.5.0-rc1
- Affected ranges
- ECOSYSTEM: ≥ 2.5.0-beta, < 2.5.1
Update to 2.5.1