p PatchFirst

CVE-2014-0001

CVE-2014-0001

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Buffer overflow in client/mysql.cc in Oracle MySQL and MariaDB before 5.5.35 allows remote database servers to cause a denial of service (crash) and possibly execute arbitrary code via a long server version string.

EPSS 6.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • mysql-5.5 Ubuntu:14.04:LTS

    Versions
    • 5.5.32-0ubuntu7
    • 5.5.34-0ubuntu1
    • 5.5.34-0ubuntu2
    • 5.5.35-0ubuntu1
    • 5.5.35+dfsg-1ubuntu1
    Affected ranges
    • ECOSYSTEM: < 5.5.37-0ubuntu0.14.04.1

    Update to 5.5.37-0ubuntu0.14.04.1

  • mysql-5.6 Ubuntu:14.04:LTS

    Versions
    • 5.6.15-0ubuntu1
    • 5.6.15-1~exp2
    • 5.6.16-1~exp1
    Affected ranges
    • ECOSYSTEM: < 5.6.17-0ubuntu0.14.04.1

    Update to 5.6.17-0ubuntu0.14.04.1

Original sources

Check your server →