p PatchFirst

CVE-2014-0081

CVE-2014-0081

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple cross-site scripting (XSS) vulnerabilities in actionview/lib/action_view/helpers/number_helper.rb in Ruby on Rails before 3.2.17, 4.0.x before 4.0.3, and 4.1.x before 4.1.0.beta2 allow remote attackers to inject arbitrary web script or HTML via the (1) format, (2) negative_format, or (3) units parameter to the (a) number_to_currency, (b) number_to_percentage, or (c) number_to_human helper.

EPSS 4.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rails Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.3.14.1

    Update to 2.3.14.1

  • rails Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.3.14.1

    Update to 2.3.14.1

  • rails Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.3.14.1

    Update to 2.3.14.1

Original sources

Check your server →