p PatchFirst

CVE-2014-0092

CVE-2014-0092

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

lib/x509/verify.c in GnuTLS before 3.1.22 and 3.2.x before 3.2.12 does not properly handle unspecified errors when verifying X.509 certificates from SSL servers, which allows man-in-the-middle attackers to spoof servers via a crafted certificate.

EPSS 29.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • gnutls28 Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.2.11-2

    Update to 3.2.11-2

  • gnutls28 Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.2.11-2

    Update to 3.2.11-2

  • gnutls28 Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.2.11-2

    Update to 3.2.11-2

  • gnutls26 Ubuntu:14.04:LTS

    Versions
    • 2.12.23-1ubuntu4
    • 2.12.23-1ubuntu5
    • 2.12.23-12ubuntu1
    Affected ranges
    • ECOSYSTEM: < 2.12.23-12ubuntu2

    Update to 2.12.23-12ubuntu2

Original sources

Check your server →