p PatchFirst

CVE-2014-0119

CVE-2014-0119

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Apache Tomcat before 6.0.40, 7.x before 7.0.54, and 8.x before 8.0.6 does not properly constrain the class loader that accesses the XML parser used with an XSLT stylesheet, which allows remote attackers to (1) read arbitrary files via a crafted web application that provides an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue, or (2) read files associated with different web applications on a single Tomcat instance via a crafted web application.

EPSS 7.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • tomcat6 Ubuntu:14.04:LTS

    Versions
    • 6.0.37-1
    • 6.0.39-1
    Affected ranges
    • ECOSYSTEM: < 6.0.39-1ubuntu0.1

    Update to 6.0.39-1ubuntu0.1

  • tomcat7 Ubuntu:14.04:LTS

    Versions
    • 7.0.42-1
    • 7.0.47-1
    • 7.0.50-1
    • 7.0.52-1
    • 7.0.52-1ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 7.0.52-1ubuntu0.3

    Update to 7.0.52-1ubuntu0.3

Original sources

Check your server →