CVE-2014-0123
CVE-2014-0123
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The wiki subsystem in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2 does not properly restrict (1) view and (2) edit access, which allows remote authenticated users to perform wiki operations by leveraging the student role and using the Recent Activity block to reach the individual wiki of an arbitrary student.
EPSS 1.5% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
moodle/moodle Packagist
- Versions
- v2.3.10
- v2.3.11
- v2.3.4
- v2.3.5
- v2.3.6
- v2.3.7
- v2.3.8
- v2.3.9
- v2.4.0
- v2.4.0-rc1
- v2.4.1
- v2.4.2
- v2.4.3
- v2.4.4
- v2.4.5
- v2.4.6
- v2.4.7
- v2.4.8
- Affected ranges
- ECOSYSTEM: < 2.4.9
Update to 2.4.9
moodle/moodle Packagist
- Versions
- v2.5.0
- v2.5.1
- v2.5.2
- v2.5.3
- v2.5.4
- Affected ranges
- ECOSYSTEM: ≥ 2.5.0, < 2.5.5
Update to 2.5.5
moodle/moodle Packagist
- Versions
- v2.6.0
- v2.6.1
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.6.2
Update to 2.6.2