CVE-2014-0190
CVE-2014-0190
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The GIF decoder in QtGui in Qt before 5.3 allows remote attackers to cause a denial of service (NULL pointer dereference) via invalid width and height values in a GIF image.
EPSS 4.0% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
qt4-x11 Ubuntu:14.04:LTS
- Versions
- 4:4.8.4+dfsg-0ubuntu18
- 4:4.8.4+dfsg-0ubuntu19
- 4:4.8.4+dfsg-0ubuntu20
- 4:4.8.4+dfsg-0ubuntu21
- 4:4.8.4+dfsg-0ubuntu22
- 4:4.8.5+git192-g085f851+dfsg-2ubuntu3
- 4:4.8.5+git192-g085f851+dfsg-2ubuntu4
- Affected ranges
- ECOSYSTEM: < 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1
Update to 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1
qtbase-opensource-src Ubuntu:14.04:LTS
- Versions
- 5.0.2+dfsg1-7ubuntu11
- 5.0.2+dfsg1-7ubuntu12
- 5.0.2+dfsg1-7ubuntu13
- 5.0.2+dfsg1-7ubuntu14
- 5.0.2+dfsg1-7ubuntu15
- 5.0.2+dfsg1-7ubuntu16
- 5.0.2+dfsg1-7ubuntu17
- 5.0.2+dfsg1-7ubuntu18
- 5.2.1+dfsg-1ubuntu7
- 5.2.1+dfsg-1ubuntu8
- 5.2.1+dfsg-1ubuntu9
- 5.2.1+dfsg-1ubuntu10
- 5.2.1+dfsg-1ubuntu11
- 5.2.1+dfsg-1ubuntu13
- 5.2.1+dfsg-1ubuntu14
- 5.2.1+dfsg-1ubuntu14.2
- Affected ranges
- ECOSYSTEM: < 5.2.1+dfsg-1ubuntu14.3
Update to 5.2.1+dfsg-1ubuntu14.3
Original sources
- https://bugs.kde.org/show_bug.cgi?id=333404
- http://lists.opensuse.org/opensuse-updates/2015-03/msg00068.html
- http://lists.fedoraproject.org/pipermail/package-announce/2014-June/134040.html
- http://www.ubuntu.com/usn/USN-2626-1
- http://lists.qt-project.org/pipermail/announce/2014-April/000045.html
- http://lists.fedoraproject.org/pipermail/package-announce/2014-June/134141.html
- http://lists.fedoraproject.org/pipermail/package-announce/2014-May/132395.html
- http://www.securityfocus.com/bid/67087
- https://nvd.nist.gov/vuln/detail/CVE-2014-0190