CVE-2014-0474
CVE-2014-0474
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The (1) FilePathField, (2) GenericIPAddressField, and (3) IPAddressField model field classes in Django before 1.4.11, 1.5.x before 1.5.6, 1.6.x before 1.6.3, and 1.7.x before 1.7 beta 2 do not properly perform type conversion, which allows remote attackers to have unspecified impact and vectors, related to "MySQL typecasting."
CVSS 9.8 · Critical · EPSS 4.9% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
python-django Debian:12
- Affected ranges
- ECOSYSTEM: < 1.6.3-1
Update to 1.6.3-1
python-django Debian:13
- Affected ranges
- ECOSYSTEM: < 1.6.3-1
Update to 1.6.3-1
python-django Debian:14
- Affected ranges
- ECOSYSTEM: < 1.6.3-1
Update to 1.6.3-1
django PyPI
- Versions
- 1.0.1
- 1.0.2
- 1.0.3
- 1.0.4
- 1.1
- 1.1.1
- 1.1.2
- 1.1.3
- 1.1.4
- 1.2
- 1.2.1
- 1.2.2
- 1.2.3
- 1.2.4
- 1.2.5
- 1.2.6
- 1.2.7
- 1.3
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 1.3.7
- 1.4
- 1.4.1
- 1.4.10
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5
- 1.4.6
- 1.4.7
- 1.4.8
- 1.4.9
- Affected ranges
- ECOSYSTEM: < 1.4.11
Update to 1.4.11
django PyPI
- Versions
- 1.5
- 1.5.1
- 1.5.2
- 1.5.3
- 1.5.4
- 1.5.5
- Affected ranges
- ECOSYSTEM: ≥ 1.5, < 1.5.6
Update to 1.5.6
django PyPI
- Versions
- 1.6
- 1.6.1
- 1.6.2
- Affected ranges
- ECOSYSTEM: ≥ 1.6, < 1.6.3
Update to 1.6.3
django PyPI
- Versions
- 1.0.1
- 1.0.2
- 1.0.3
- 1.0.4
- 1.1
- 1.1.1
- 1.1.2
- 1.1.3
- 1.1.4
- 1.2
- 1.2.1
- 1.2.2
- 1.2.3
- 1.2.4
- 1.2.5
- 1.2.6
- 1.2.7
- 1.3
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 1.3.7
- 1.4
- 1.4.1
- 1.4.10
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5
- 1.4.6
- 1.4.7
- 1.4.8
- 1.4.9
- 1.5
- 1.5.1
- 1.5.2
- 1.5.3
- 1.5.4
- 1.5.5
- 1.6
- 1.6.1
- 1.6.2
- Affected ranges
- ECOSYSTEM: < 1.4.11 ∪ ≥ 1.5, < 1.5.6 ∪ ≥ 1.6, < 1.6.3
Update to 1.4.11; Update to 1.5.6; Update to 1.6.3
python-django Ubuntu:14.04:LTS
- Versions
- 1.5.4-1ubuntu1
- 1.6-1
- 1.6.1-1
- 1.6.1-2
- Affected ranges
- ECOSYSTEM: < 1.6.1-2ubuntu0.1
Update to 1.6.1-2ubuntu0.1
Original sources
- http://www.ubuntu.com/usn/USN-2169-1
- https://www.djangoproject.com/weblog/2014/apr/21/security/
- http://rhn.redhat.com/errata/RHSA-2014-0457.html
- http://secunia.com/advisories/61281
- http://www.debian.org/security/2014/dsa-2934
- http://lists.opensuse.org/opensuse-updates/2014-09/msg00023.html
- http://rhn.redhat.com/errata/RHSA-2014-0456.html
- https://nvd.nist.gov/vuln/detail/CVE-2014-0474