p PatchFirst

CVE-2014-1610

CVE-2014-1610

This page contains facts from public vulnerability sources. Check the original advisory before updating.

MediaWiki 1.22.x before 1.22.2, 1.21.x before 1.21.5, and 1.19.x before 1.19.11, when DjVu or PDF file upload support is enabled, allows remote attackers to execute arbitrary commands via shell metacharacters in (1) the page parameter to includes/media/DjVu.php; (2) the w parameter (aka width field) to thumb.php, which is not properly handled by includes/media/PdfHandler_body.php; and possibly unspecified vectors in (3) includes/media/Bitmap.php and (4) includes/media/ImageHandler.php.

EPSS 42.8% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • mediawiki Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:1.19.11+dfsg-1

    Update to 1:1.19.11+dfsg-1

  • mediawiki Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:1.19.11+dfsg-1

    Update to 1:1.19.11+dfsg-1

  • mediawiki Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:1.19.11+dfsg-1

    Update to 1:1.19.11+dfsg-1

Original sources

Check your server →