CVE-2014-1927
CVE-2014-1927
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The shell_quote function in python-gnupg 0.3.5 does not properly quote strings, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "$(" command-substitution sequences, a different vulnerability than CVE-2014-1928. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
CVSS 8.7 · High · EPSS 3.4% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
python-gnupg Debian:12
- Affected ranges
- ECOSYSTEM: < 0.3.6-1
Update to 0.3.6-1
python-gnupg Debian:13
- Affected ranges
- ECOSYSTEM: < 0.3.6-1
Update to 0.3.6-1
python-gnupg Debian:14
- Affected ranges
- ECOSYSTEM: < 0.3.6-1
Update to 0.3.6-1
python-gnupg PyPI
- Versions
- 0.3.5
- Affected ranges
- ECOSYSTEM: ≥ 0.3.5, < 0.3.6
Update to 0.3.6
python-gnupg Ubuntu:14.04:LTS
- Versions
- 0.3.5-2
- Affected ranges
- ECOSYSTEM: < 0.3.6-1
Update to 0.3.6-1
Original sources
- http://secunia.com/advisories/56616
- http://www.debian.org/security/2014/dsa-2946
- http://seclists.org/oss-sec/2014/q1/245
- https://code.google.com/p/python-gnupg/issues/detail?id=98
- https://code.google.com/p/python-gnupg/
- http://seclists.org/oss-sec/2014/q1/294
- http://secunia.com/advisories/59031
- https://nvd.nist.gov/vuln/detail/CVE-2014-1927