p PatchFirst

CVE-2014-1928

CVE-2014-1928

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "\" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.

CVSS 8.7 · High · EPSS 0.6% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • python-gnupg Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.3.6-1

    Update to 0.3.6-1

  • python-gnupg Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.3.6-1

    Update to 0.3.6-1

  • python-gnupg Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.3.6-1

    Update to 0.3.6-1

  • python-gnupg PyPI

    Versions
    • 0.3.5
    Affected ranges
    • ECOSYSTEM: ≥ 0.3.5, < 0.3.6

    Update to 0.3.6

  • python-gnupg PyPI

    Versions
    • 0.2.3
    • 0.2.4
    • 0.2.6
    • 0.2.7
    • 0.2.8
    • 0.2.9
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 0.3.3
    • 0.3.4
    • 0.3.5
    Affected ranges
    • ECOSYSTEM: < 0.3.6

    Update to 0.3.6

Original sources

Check your server →