CVE-2014-1958
CVE-2014-1958
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Buffer overflow in the DecodePSDPixels function in coders/psd.c in ImageMagick before 6.8.8-5 might allow remote attackers to execute arbitrary code via a crafted PSD image, involving the L%06ld string, a different vulnerability than CVE-2014-2030.
CVSS 8.8 · High · EPSS 3.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
imagemagick Debian:12
- Affected ranges
- ECOSYSTEM: < 8:6.7.7.10+dfsg-1
Update to 8:6.7.7.10+dfsg-1
imagemagick Debian:13
- Affected ranges
- ECOSYSTEM: < 8:6.7.7.10+dfsg-1
Update to 8:6.7.7.10+dfsg-1
imagemagick Debian:14
- Affected ranges
- ECOSYSTEM: < 8:6.7.7.10+dfsg-1
Update to 8:6.7.7.10+dfsg-1
Original sources
- http://trac.imagemagick.org/changeset/14801
- http://www.openwall.com/lists/oss-security/2014/02/13/2
- http://www.openwall.com/lists/oss-security/2014/02/13/5
- http://lists.opensuse.org/opensuse-updates/2014-03/msg00032.html
- http://lists.opensuse.org/opensuse-updates/2014-03/msg00039.html
- http://ubuntu.com/usn/usn-2132-1
- https://www.openwall.com/lists/oss-security/2014/02/19/13
- https://nvd.nist.gov/vuln/detail/CVE-2014-1958