CVE-2014-1959
CVE-2014-1959
This page contains facts from public vulnerability sources. Check the original advisory before updating.
lib/x509/verify.c in GnuTLS before 3.1.21 and 3.2.x before 3.2.11 treats version 1 X.509 certificates as intermediate CAs, which allows remote attackers to bypass intended restrictions by leveraging a X.509 V1 certificate from a trusted CA to issue new certificates.
EPSS 3.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
gnutls28 Debian:12
- Affected ranges
- ECOSYSTEM: < 3.2.11-1
Update to 3.2.11-1
gnutls28 Debian:13
- Affected ranges
- ECOSYSTEM: < 3.2.11-1
Update to 3.2.11-1
gnutls28 Debian:14
- Affected ranges
- ECOSYSTEM: < 3.2.11-1
Update to 3.2.11-1
gnutls26 Ubuntu:14.04:LTS
- Versions
- 2.12.23-1ubuntu4
- 2.12.23-1ubuntu5
- Affected ranges
- ECOSYSTEM: < 2.12.23-12ubuntu1
Update to 2.12.23-12ubuntu1
Original sources
- http://www.gnutls.org/security.html
- http://seclists.org/oss-sec/2014/q1/344
- http://seclists.org/oss-sec/2014/q1/345
- http://www.securityfocus.com/bid/65559
- http://www.ubuntu.com/usn/USN-2121-1
- https://www.gitorious.org/gnutls/gnutls/commit/b1abfe3d182d68539900092eb42fc62cf1bb7e7c
- http://www.debian.org/security/2014/dsa-2866
- https://nvd.nist.gov/vuln/detail/CVE-2014-1959