CVE-2014-2015
CVE-2014-2015
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Stack-based buffer overflow in the normify function in the rlm_pap module (modules/rlm_pap/rlm_pap.c) in FreeRADIUS 2.x, possibly 2.2.3 and earlier, and 3.x, possibly 3.0.1 and earlier, might allow attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long password hash, as demonstrated by an SSHA hash.
EPSS 3.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
freeradius Debian:12
- Affected ranges
- ECOSYSTEM: < 2.2.5+dfsg-0.1
Update to 2.2.5+dfsg-0.1
freeradius Debian:13
- Affected ranges
- ECOSYSTEM: < 2.2.5+dfsg-0.1
Update to 2.2.5+dfsg-0.1
freeradius Debian:14
- Affected ranges
- ECOSYSTEM: < 2.2.5+dfsg-0.1
Update to 2.2.5+dfsg-0.1
Original sources
- http://lists.freebsd.org/pipermail/freebsd-bugbusters/2014-February/000616.html
- http://www.openwall.com/lists/oss-security/2014/02/18/3
- http://rhn.redhat.com/errata/RHSA-2015-1287.html
- http://lists.freebsd.org/pipermail/freebsd-bugbusters/2014-February/000612.html
- http://ubuntu.com/usn/usn-2122-1
- http://lists.freebsd.org/pipermail/freebsd-bugbusters/2014-February/000610.html
- http://www.securityfocus.com/bid/65581
- https://bugzilla.redhat.com/show_bug.cgi?id=1066761
- https://nvd.nist.gov/vuln/detail/CVE-2014-2015