p PatchFirst

CVE-2014-2299

CVE-2014-2299

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Buffer overflow in the mpeg_read function in wiretap/mpeg.c in the MPEG parser in Wireshark 1.8.x before 1.8.13 and 1.10.x before 1.10.6 allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via a large record in MPEG data.

EPSS 47.1% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wireshark Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.10.6-1

    Update to 1.10.6-1

  • wireshark Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.10.6-1

    Update to 1.10.6-1

  • wireshark Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.10.6-1

    Update to 1.10.6-1

  • wireshark Ubuntu:14.04:LTS

    Versions
    • 1.10.2-1
    • 1.10.3-1
    • 1.10.5-1ubuntu1
    • 1.10.5-2
    Affected ranges
    • ECOSYSTEM: < 1.10.6-1

    Update to 1.10.6-1

Original sources

Check your server →