CVE-2014-2338
CVE-2014-2338
This page contains facts from public vulnerability sources. Check the original advisory before updating.
IKEv2 in strongSwan 4.0.7 before 5.1.3 allows remote attackers to bypass authentication by rekeying an IKE_SA during (1) initiation or (2) re-authentication, which triggers the IKE_SA state to be set to established.
EPSS 2.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
strongswan Debian:12
- Affected ranges
- ECOSYSTEM: < 5.1.2-4
Update to 5.1.2-4
strongswan Debian:13
- Affected ranges
- ECOSYSTEM: < 5.1.2-4
Update to 5.1.2-4
strongswan Debian:14
- Affected ranges
- ECOSYSTEM: < 5.1.2-4
Update to 5.1.2-4
strongswan Ubuntu:14.04:LTS
- Versions
- 4.6.4-9
- 5.1.0-2
- 5.1.0-3
- 5.1.1-0ubuntu1
- 5.1.1-0ubuntu2
- 5.1.1-0ubuntu3
- 5.1.1-0ubuntu4
- 5.1.1-0ubuntu5
- 5.1.1-0ubuntu7
- 5.1.1-0ubuntu14
- 5.1.1-0ubuntu17
- 5.1.2~dr3+git20130120-0ubuntu2
- 5.1.2~dr3+git20130120-0ubuntu3
- 5.1.2~rc1-0ubuntu3
- 5.1.2~rc1-0ubuntu4
- 5.1.2~rc2-0ubuntu2
- 5.1.2-0ubuntu1
- Affected ranges
- ECOSYSTEM: < 5.1.2-0ubuntu2
Update to 5.1.2-0ubuntu2
Original sources
- http://lists.opensuse.org/opensuse-updates/2014-05/msg00064.html
- http://lists.opensuse.org/opensuse-security-announce/2014-04/msg00010.html
- http://lists.opensuse.org/opensuse-updates/2014-05/msg00066.html
- http://www.debian.org/security/2014/dsa-2903
- http://secunia.com/advisories/57823
- http://www.securityfocus.com/bid/66815
- http://www.strongswan.org/blog/2014/04/14/strongswan-authentication-bypass-vulnerability-%28cve-2014-2338%29.html
- https://nvd.nist.gov/vuln/detail/CVE-2014-2338