CVE-2014-2571
CVE-2014-2571
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Cross-site scripting (XSS) vulnerability in the quiz_question_tostring function in mod/quiz/editlib.php in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2 allows remote authenticated users to inject arbitrary web script or HTML via a quiz question.
EPSS 1.0% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
moodle/moodle Packagist
- Versions
- v2.3.10
- v2.3.11
- v2.3.4
- v2.3.5
- v2.3.6
- v2.3.7
- v2.3.8
- v2.3.9
- v2.4.0
- v2.4.0-rc1
- v2.4.1
- v2.4.2
- v2.4.3
- v2.4.4
- v2.4.5
- v2.4.6
- v2.4.7
- v2.4.8
- Affected ranges
- ECOSYSTEM: < 2.4.9
Update to 2.4.9
moodle/moodle Packagist
- Versions
- v2.5.0
- v2.5.1
- v2.5.2
- v2.5.3
- v2.5.4
- Affected ranges
- ECOSYSTEM: ≥ 2.5.0, < 2.5.5
Update to 2.5.5
moodle/moodle Packagist
- Versions
- v2.6.0
- v2.6.1
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.6.2
Update to 2.6.2