CVE-2014-2669
CVE-2014-2669
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Multiple integer overflows in contrib/hstore/hstore_io.c in PostgreSQL 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 allow remote authenticated users to have unspecified impact via vectors related to the (1) hstore_recv, (2) hstore_from_arrays, and (3) hstore_from_array functions in contrib/hstore/hstore_io.c; and the (4) hstoreArrayToPairs function in contrib/hstore/hstore_op.c, which triggers a buffer overflow. NOTE: this issue was SPLIT from CVE-2014-0064 because it has a different set of affected versions.
EPSS 3.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
postgresql-9.1 Ubuntu:14.04:LTS
- Versions
- 9.1.10-1
- 9.1.10-1bzr1
- 9.1.11-1
- 9.1.11-2
- Affected ranges
- ECOSYSTEM: < 9.1.12-1
Update to 9.1.12-1
Original sources
- http://rhn.redhat.com/errata/RHSA-2014-0221.html
- http://rhn.redhat.com/errata/RHSA-2014-0469.html
- https://github.com/postgres/postgres/commit/31400a673325147e1205326008e32135a78b4d8a
- http://wiki.postgresql.org/wiki/20140220securityrelease
- http://www.debian.org/security/2014/dsa-2864
- http://www.postgresql.org/support/security/
- http://www.postgresql.org/about/news/1506/
- http://www.debian.org/security/2014/dsa-2865
- https://nvd.nist.gov/vuln/detail/CVE-2014-2669