CVE-2014-2682
CVE-2014-2682
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Zend Framework 1 (ZF1) before 1.12.4, Zend Framework 2 before 2.1.6 and 2.2.x before 2.2.6, ZendOpenId, ZendRest, ZendService_AudioScrobbler, ZendService_Nirvanix, ZendService_SlideShare, ZendService_Technorati, and ZendService_WindowsAzure before 2.0.2, ZendService_Amazon before 2.0.3, and ZendService_Api before 1.0.0, when PHP-FPM is used, does not properly share the libxml_disable_entity_loader setting between threads, which might allow remote attackers to conduct XML External Entity (XXE) attacks via an XML external entity declaration in conjunction with an entity reference. NOTE: this issue exists because of an incomplete fix for CVE-2012-5657.
EPSS 2.2% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
zendframework/zendframework1 Packagist
- Versions
- 1.12.0
- 1.12.1
- 1.12.2
- 1.12.3
- Affected ranges
- ECOSYSTEM: < 1.12.4
Update to 1.12.4
zendframework/zendopenid Packagist
- Versions
- 2.0.0
- 2.0.0rc1
- 2.0.0rc2
- 2.0.0rc3
- 2.0.0rc4
- 2.0.0rc5
- 2.0.0rc6
- 2.0.0rc7
- 2.0.1
- Affected ranges
- ECOSYSTEM: < 2.0.2
Update to 2.0.2
zendframework/zendrest Packagist
- Versions
- 2.0.0
- 2.0.0rc1
- 2.0.0rc2
- 2.0.0rc3
- 2.0.0rc4
- 2.0.0rc5
- 2.0.0rc6
- 2.0.0rc7
- 2.0.1
- Affected ranges
- ECOSYSTEM: < 2.0.2
Update to 2.0.2
zendframework/zendservice-audioscrobbler Packagist
- Versions
- 2.0.0
- 2.0.0rc1
- 2.0.0rc2
- 2.0.0rc3
- 2.0.0rc4
- 2.0.0rc5
- 2.0.0rc6
- 2.0.0rc7
- 2.0.1
- Affected ranges
- ECOSYSTEM: < 2.0.2
Update to 2.0.2
zendframework/zendservice-nirvanix Packagist
- Versions
- 2.0.0
- 2.0.0rc1
- 2.0.0rc2
- 2.0.0rc3
- 2.0.0rc4
- 2.0.0rc5
- 2.0.0rc6
- 2.0.0rc7
- 2.0.1
- Affected ranges
- ECOSYSTEM: < 2.0.2
Update to 2.0.2
zendframework/zendservice-slideshare Packagist
- Versions
- 2.0.0
- 2.0.0rc1
- 2.0.0rc2
- 2.0.0rc3
- 2.0.0rc4
- 2.0.0rc5
- 2.0.0rc6
- 2.0.0rc7
- 2.0.1
- Affected ranges
- ECOSYSTEM: < 2.0.2
Update to 2.0.2
zendframework/zendservice-technorati Packagist
- Versions
- 2.0.0
- 2.0.0rc1
- 2.0.0rc2
- 2.0.0rc3
- 2.0.0rc4
- 2.0.0rc5
- 2.0.0rc6
- 2.0.0rc7
- 2.0.1
- Affected ranges
- ECOSYSTEM: < 2.0.2
Update to 2.0.2
zendframework/zendservice-windowsazure Packagist
- Versions
- 2.0.0
- 2.0.0rc1
- 2.0.0rc2
- 2.0.0rc3
- 2.0.0rc4
- 2.0.0rc5
- 2.0.0rc6
- 2.0.0rc7
- 2.0.1
- Affected ranges
- ECOSYSTEM: < 2.0.2
Update to 2.0.2
zendframework/zendservice-amazon Packagist
- Versions
- 2.0.0
- 2.0.0rc1
- 2.0.0rc2
- 2.0.0rc3
- 2.0.0rc4
- 2.0.0rc5
- 2.0.0rc6
- 2.0.0rc7
- 2.0.1
- 2.0.2
- Affected ranges
- ECOSYSTEM: < 2.0.3
Update to 2.0.3
zendframework/zendservice-api Packagist
- Versions
- 1.0.0beta1
- Affected ranges
- ECOSYSTEM: < 1.0.0
Update to 1.0.0
Original sources
- http://seclists.org/oss-sec/2014/q2/0
- http://www.mandriva.com/security/advisories?name=MDVSA-2014:072
- http://advisories.mageia.org/MGASA-2014-0151.html
- http://www.securityfocus.com/bid/66358
- http://www.debian.org/security/2015/dsa-3265
- http://framework.zend.com/security/advisory/ZF2014-01
- https://nvd.nist.gov/vuln/detail/CVE-2014-2682