CVE-2014-3146
CVE-2014-3146
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Incomplete blacklist vulnerability in the lxml.html.clean module in lxml before 3.3.5 allows remote attackers to conduct cross-site scripting (XSS) attacks via control characters in the link scheme to the clean_html function.
CVSS 6.1 · Medium · EPSS 6.3% · Public exploit · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
lxml Debian:12
- Affected ranges
- ECOSYSTEM: < 3.3.5-1
Update to 3.3.5-1
lxml Debian:13
- Affected ranges
- ECOSYSTEM: < 3.3.5-1
Update to 3.3.5-1
lxml Debian:14
- Affected ranges
- ECOSYSTEM: < 3.3.5-1
Update to 3.3.5-1
lxml PyPI
- Versions
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 2.0
- 2.0.10
- 2.0.11
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.0.8
- 2.0.9
- 2.1
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.1.5
- 2.2
- 2.2.1
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- 2.2.7
- 2.2.8
- 2.3
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.3.5
- 2.3.6
- 3.0
- 3.0.2
- 3.1.0
- 3.1.1
- 3.1.2
- 3.2.0
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.2.5
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.3.4
- Affected ranges
- ECOSYSTEM: < 3.3.5
Update to 3.3.5
lxml PyPI
- Versions
- 0.9
- 0.9.1
- 0.9.2
- 1.0
- 1.0.1
- 1.0.2
- 1.0.3
- 1.0.4
- 1.0.beta
- 1.1
- 1.1.1
- 1.1.2
- 1.1alpha
- 1.1beta
- 1.2
- 1.2.1
- 1.3
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 1.3beta
- 2.0
- 2.0.1
- 2.0.10
- 2.0.11
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.0.8
- 2.0.9
- 2.0alpha1
- 2.0alpha2
- 2.0alpha3
- 2.0alpha4
- 2.0alpha5
- 2.0alpha6
- 2.0beta1
- 2.0beta2
- 2.1
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.1.5
- 2.1alpha1
- 2.1beta1
- 2.1beta2
- 2.1beta3
- 2.2
- 2.2.1
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- 2.2.7
- 2.2.8
- 2.2alpha1
- 2.2beta1
- 2.2beta2
- 2.2beta3
- 2.2beta4
- 2.3
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.3.5
- 2.3.6
- 2.3alpha1
- 2.3alpha2
- 2.3beta1
- 3.0
- 3.0.1
- 3.0.2
- 3.1.0
- 3.1.1
- 3.1.2
- 3.1beta1
- 3.2.0
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.2.5
- 3.3.0
- 3.3.0beta1
- 3.3.0beta2
- 3.3.0beta3
- 3.3.0beta4
- 3.3.0beta5
- 3.3.1
- 3.3.2
- 3.3.3
- 3.3.4
- Affected ranges
- ECOSYSTEM: < 3.3.5
Update to 3.3.5
lxml Ubuntu:14.04:LTS
- Versions
- 3.2.0-1
- 3.3.0~beta2-1
- 3.3.0~beta4-1
- 3.3.1-1
- 3.3.2-1
- 3.3.2-1build1
- 3.3.3-1
- Affected ranges
- ECOSYSTEM: < 3.3.3-1ubuntu0.1
Update to 3.3.3-1ubuntu0.1
Original sources
- http://www.debian.org/security/2014/dsa-2941
- http://lxml.de/3.3/changes-3.3.5.html
- http://www.openwall.com/lists/oss-security/2014/05/09/7
- http://www.ubuntu.com/usn/USN-2217-1
- https://mailman-mail5.webfaction.com/pipermail/lxml/2014-April/007128.html
- http://secunia.com/advisories/58744
- http://advisories.mageia.org/MGASA-2014-0218.html
- http://www.securityfocus.com/bid/67159
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:112
- http://secunia.com/advisories/58013
- http://seclists.org/fulldisclosure/2014/Apr/210
- http://secunia.com/advisories/59008
- http://lists.opensuse.org/opensuse-updates/2014-05/msg00083.html
- http://seclists.org/fulldisclosure/2014/Apr/319
- https://nvd.nist.gov/vuln/detail/CVE-2014-3146