p PatchFirst

CVE-2014-3482

CVE-2014-3482

This page contains facts from public vulnerability sources. Check the original advisory before updating.

SQL injection vulnerability in activerecord/lib/active_record/connection_adapters/postgresql_adapter.rb in the PostgreSQL adapter for Active Record in Ruby on Rails 2.x and 3.x before 3.2.19 allows remote attackers to execute arbitrary SQL commands by leveraging improper bitstring quoting.

EPSS 4.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rails Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:4.1.4-1

    Update to 2:4.1.4-1

  • rails Debian:13

    Affected ranges
    • ECOSYSTEM: < 2:4.1.4-1

    Update to 2:4.1.4-1

  • rails Debian:14

    Affected ranges
    • ECOSYSTEM: < 2:4.1.4-1

    Update to 2:4.1.4-1

Original sources

Check your server →