p PatchFirst

CVE-2014-3483

CVE-2014-3483

This page contains facts from public vulnerability sources. Check the original advisory before updating.

SQL injection vulnerability in activerecord/lib/active_record/connection_adapters/postgresql/quoting.rb in the PostgreSQL adapter for Active Record in Ruby on Rails 4.x before 4.0.7 and 4.1.x before 4.1.3 allows remote attackers to execute arbitrary SQL commands by leveraging improper range quoting.

EPSS 4.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rails Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:4.1.4-1

    Update to 2:4.1.4-1

  • rails Debian:13

    Affected ranges
    • ECOSYSTEM: < 2:4.1.4-1

    Update to 2:4.1.4-1

  • rails Debian:14

    Affected ranges
    • ECOSYSTEM: < 2:4.1.4-1

    Update to 2:4.1.4-1

Original sources

Check your server →