CVE-2014-3551
CVE-2014-3551
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Multiple cross-site scripting (XSS) vulnerabilities in the advanced-grading implementation in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) qualification or (2) rating field in a rubric.
EPSS 1.7% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
moodle/moodle Packagist
- Versions
- v2.3.10
- v2.3.11
- v2.3.4
- v2.3.5
- v2.3.6
- v2.3.7
- v2.3.8
- v2.3.9
- v2.4.0
- v2.4.0-rc1
- v2.4.1
- v2.4.10
- v2.4.2
- v2.4.3
- v2.4.4
- v2.4.5
- v2.4.6
- v2.4.7
- v2.4.8
- v2.4.9
- Affected ranges
- ECOSYSTEM: < 2.4.11
Update to 2.4.11
moodle/moodle Packagist
- Versions
- v2.5.0
- v2.5.1
- v2.5.2
- v2.5.3
- v2.5.4
- v2.5.5
- v2.5.6
- Affected ranges
- ECOSYSTEM: ≥ 2.5.0, < 2.5.7
Update to 2.5.7
moodle/moodle Packagist
- Versions
- v2.6.0
- v2.6.1
- v2.6.2
- v2.6.3
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.6.4
Update to 2.6.4
moodle/moodle Packagist
- Versions
- v2.7.0
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 2.7.1
Update to 2.7.1