CVE-2014-3594
CVE-2014-3594
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Cross-site scripting (XSS) vulnerability in the Host Aggregates interface in OpenStack Dashboard (Horizon) before 2013.2.4, 2014.1 before 2014.1.2, and Juno before Juno-3 allows remote administrators to inject arbitrary web script or HTML via a new host aggregate name.
EPSS 2.1% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
horizon Debian:12
- Affected ranges
- ECOSYSTEM: < 2014.1.2-3
Update to 2014.1.2-3
horizon Debian:13
- Affected ranges
- ECOSYSTEM: < 2014.1.2-3
Update to 2014.1.2-3
horizon Debian:14
- Affected ranges
- ECOSYSTEM: < 2014.1.2-3
Update to 2014.1.2-3
horizon PyPI
- Affected ranges
- ECOSYSTEM: < 8.0.0a0
Update to 8.0.0a0
horizon Ubuntu:14.04:LTS
- Versions
- 1:2013.2~rc3-0ubuntu1
- 1:2013.2-0ubuntu1
- 1:2014.1~b1-0ubuntu1
- 1:2014.1~b2-0ubuntu1
- 1:2014.1~b2-0ubuntu2
- 1:2014.1~b3-0ubuntu1
- 1:2014.1~b3-0ubuntu2
- 1:2014.1~rc1-0ubuntu1
- 1:2014.1~rc2-0ubuntu1
- 1:2014.1-0ubuntu1
- 1:2014.1.1-0ubuntu1
- 1:2014.1.2-0ubuntu1
- Affected ranges
- ECOSYSTEM: < 1:2014.1.2-0ubuntu1.1
Update to 1:2014.1.2-0ubuntu1.1
Original sources
- http://rhn.redhat.com/errata/RHSA-2014-1336.html
- http://www.securityfocus.com/bid/69291
- https://review.openstack.org/#/c/115313/
- http://rhn.redhat.com/errata/RHSA-2014-1335.html
- https://review.openstack.org/#/c/115311
- https://review.openstack.org/#/c/115310
- http://seclists.org/oss-sec/2014/q3/413
- https://bugs.launchpad.net/horizon/+bug/1349491
- http://lists.opensuse.org/opensuse-updates/2015-01/msg00040.html
- https://exchange.xforce.ibmcloud.com/vulnerabilities/95378
- https://nvd.nist.gov/vuln/detail/CVE-2014-3594