p PatchFirst

CVE-2014-3694

CVE-2014-3694

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The (1) bundled GnuTLS SSL/TLS plugin and the (2) bundled OpenSSL SSL/TLS plugin in libpurple in Pidgin before 2.10.10 do not properly consider the Basic Constraints extension during verification of X.509 certificates from SSL servers, which allows man-in-the-middle attackers to spoof servers and obtain sensitive information via a crafted certificate.

EPSS 2.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • pidgin Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.10.10-1

    Update to 2.10.10-1

  • pidgin Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.10.10-1

    Update to 2.10.10-1

  • pidgin Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.10.10-1

    Update to 2.10.10-1

  • pidgin Ubuntu:14.04:LTS

    Versions
    • 1:2.10.7-0ubuntu4.1
    • 1:2.10.7-0ubuntu4.2
    • 1:2.10.9-0ubuntu1
    • 1:2.10.9-0ubuntu2
    • 1:2.10.9-0ubuntu3
    • 1:2.10.9-0ubuntu3.1
    Affected ranges
    • ECOSYSTEM: < 1:2.10.9-0ubuntu3.2

    Update to 1:2.10.9-0ubuntu3.2

Original sources

Check your server →