CVE-2014-3698
CVE-2014-3698
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The jabber_idn_validate function in jutil.c in the Jabber protocol plugin in libpurple in Pidgin before 2.10.10 allows remote attackers to obtain sensitive information from process memory via a crafted XMPP message.
EPSS 3.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
pidgin Debian:12
- Affected ranges
- ECOSYSTEM: < 2.10.10-1
Update to 2.10.10-1
pidgin Debian:13
- Affected ranges
- ECOSYSTEM: < 2.10.10-1
Update to 2.10.10-1
pidgin Debian:14
- Affected ranges
- ECOSYSTEM: < 2.10.10-1
Update to 2.10.10-1
pidgin Ubuntu:14.04:LTS
- Versions
- 1:2.10.7-0ubuntu4.1
- 1:2.10.7-0ubuntu4.2
- 1:2.10.9-0ubuntu1
- 1:2.10.9-0ubuntu2
- 1:2.10.9-0ubuntu3
- 1:2.10.9-0ubuntu3.1
- Affected ranges
- ECOSYSTEM: < 1:2.10.9-0ubuntu3.2
Update to 1:2.10.9-0ubuntu3.2
Original sources
- http://hg.pidgin.im/pidgin/main/rev/ea46ab68f0dc
- http://pidgin.im/news/security/?id=90
- https://access.redhat.com/errata/RHSA-2017:1854
- http://www.ubuntu.com/usn/USN-2390-1
- http://lists.opensuse.org/opensuse-updates/2014-11/msg00023.html
- http://secunia.com/advisories/60741
- http://www.debian.org/security/2014/dsa-3055
- http://lists.opensuse.org/opensuse-updates/2014-11/msg00037.html
- http://secunia.com/advisories/61968
- https://nvd.nist.gov/vuln/detail/CVE-2014-3698