CVE-2014-4342
CVE-2014-4342
This page contains facts from public vulnerability sources. Check the original advisory before updating.
MIT Kerberos 5 (aka krb5) 1.7.x through 1.12.x before 1.12.2 allows remote attackers to cause a denial of service (buffer over-read or NULL pointer dereference, and application crash) by injecting invalid tokens into a GSSAPI application session.
EPSS 6.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
krb5 Debian:12
- Affected ranges
- ECOSYSTEM: < 1.12.1+dfsg-4
Update to 1.12.1+dfsg-4
krb5 Debian:13
- Affected ranges
- ECOSYSTEM: < 1.12.1+dfsg-4
Update to 1.12.1+dfsg-4
krb5 Debian:14
- Affected ranges
- ECOSYSTEM: < 1.12.1+dfsg-4
Update to 1.12.1+dfsg-4
krb5 Ubuntu:14.04:LTS
- Versions
- 1.10.1+dfsg-6.1ubuntu1
- 1.11.3+dfsg-3ubuntu2
- 1.12+dfsg-2ubuntu1
- 1.12+dfsg-2ubuntu2
- 1.12+dfsg-2ubuntu3
- 1.12+dfsg-2ubuntu4
- Affected ranges
- ECOSYSTEM: < 1.12+dfsg-2ubuntu4.2
Update to 1.12+dfsg-2ubuntu4.2
Original sources
- https://github.com/krb5/krb5/commit/e6ae703ae597d798e310368d52b8f38ee11c6a73
- http://www.securityfocus.com/bid/68908
- http://www.oracle.com/technetwork/security-advisory/cpuoct2017-3236626.html
- http://rhn.redhat.com/errata/RHSA-2015-0439.html
- http://krbdev.mit.edu/rt/Ticket/Display.html?id=7949
- http://www.debian.org/security/2014/dsa-3000
- https://exchange.xforce.ibmcloud.com/vulnerabilities/94903
- http://www.mandriva.com/security/advisories?name=MDVSA-2014:165
- http://www.securitytracker.com/id/1030706
- http://secunia.com/advisories/60082
- http://advisories.mageia.org/MGASA-2014-0345.html
- http://secunia.com/advisories/59102
- https://nvd.nist.gov/vuln/detail/CVE-2014-4342