p PatchFirst

CVE-2014-4345

CVE-2014-4345

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Off-by-one error in the krb5_encode_krbsecretkey function in plugins/kdb/ldap/libkdb_ldap/ldap_principal2.c in the LDAP KDB module in kadmind in MIT Kerberos 5 (aka krb5) 1.6.x through 1.11.x before 1.11.6 and 1.12.x before 1.12.2 allows remote authenticated users to cause a denial of service (buffer overflow) or possibly execute arbitrary code via a series of "cpw -keepold" commands.

EPSS 8.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • krb5 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.12.1+dfsg-7

    Update to 1.12.1+dfsg-7

  • krb5 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.12.1+dfsg-7

    Update to 1.12.1+dfsg-7

  • krb5 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.12.1+dfsg-7

    Update to 1.12.1+dfsg-7

  • krb5 Ubuntu:14.04:LTS

    Versions
    • 1.10.1+dfsg-6.1ubuntu1
    • 1.11.3+dfsg-3ubuntu2
    • 1.12+dfsg-2ubuntu1
    • 1.12+dfsg-2ubuntu2
    • 1.12+dfsg-2ubuntu3
    • 1.12+dfsg-2ubuntu4
    Affected ranges
    • ECOSYSTEM: < 1.12+dfsg-2ubuntu4.2

    Update to 1.12+dfsg-2ubuntu4.2

Original sources

Check your server →