CVE-2014-4658
CVE-2014-4658
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The vault subsystem in Ansible before 1.5.5 does not set the umask before creation or modification of a vault file, which allows local users to obtain sensitive key information by reading a file.
CVSS 6.8 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
ansible Debian:12
- Affected ranges
- ECOSYSTEM: < 1.5.5+dfsg-1
Update to 1.5.5+dfsg-1
ansible Debian:13
- Affected ranges
- ECOSYSTEM: < 1.5.5+dfsg-1
Update to 1.5.5+dfsg-1
ansible Debian:14
- Affected ranges
- ECOSYSTEM: < 1.5.5+dfsg-1
Update to 1.5.5+dfsg-1
ansible PyPI
- Versions
- 1.0
- 1.1
- 1.2
- 1.2.1
- 1.2.2
- 1.2.3
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.4
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5
- 1.5
- 1.5.1
- 1.5.2
- 1.5.3
- 1.5.4
- Affected ranges
- ECOSYSTEM: < 1.5.5
Update to 1.5.5
ansible Ubuntu:Pro:14.04:LTS
- Versions
- 1.1+dfsg-1
- 1.3.4+dfsg-1
- 1.4.0+dfsg-1
- 1.4.1+dfsg-1
- 1.4.3+dfsg-1
- 1.4.4+dfsg-1
- 1.5.4+dfsg-1
- 1.5.4+dfsg-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: < 1.5.4+dfsg-1ubuntu0.1~esm2
Update to 1.5.4+dfsg-1ubuntu0.1~esm2