CVE-2014-4659
CVE-2014-4659
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Ansible before 1.5.5 sets 0644 permissions for sources.list, which might allow local users to obtain sensitive credential information in opportunistic circumstances by reading a file that uses the "deb http://user:pass@server:port/" format.
CVSS 6.8 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
ansible Debian:12
- Affected ranges
- ECOSYSTEM: < 1.5.5+dfsg-1
Update to 1.5.5+dfsg-1
ansible Debian:13
- Affected ranges
- ECOSYSTEM: < 1.5.5+dfsg-1
Update to 1.5.5+dfsg-1
ansible Debian:14
- Affected ranges
- ECOSYSTEM: < 1.5.5+dfsg-1
Update to 1.5.5+dfsg-1
ansible PyPI
- Versions
- 1.0
- 1.1
- 1.2
- 1.2.1
- 1.2.2
- 1.2.3
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.4
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5
- 1.5
- 1.5.1
- 1.5.2
- 1.5.3
- 1.5.4
- Affected ranges
- ECOSYSTEM: < 1.5.5
Update to 1.5.5