p PatchFirst

CVE-2014-4877

CVE-2014-4877

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Absolute path traversal vulnerability in GNU Wget before 1.16, when recursion is enabled, allows remote FTP servers to write to arbitrary files, and consequently execute arbitrary code, via a LIST response that references the same filename within two entries, one of which indicates that the filename is for a symlink.

EPSS 39.9% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wget Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.16-1

    Update to 1.16-1

  • wget Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.16-1

    Update to 1.16-1

  • wget Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.16-1

    Update to 1.16-1

  • wget Ubuntu:14.04:LTS

    Versions
    • 1.14-2ubuntu1
    • 1.14-5ubuntu1
    • 1.15-1ubuntu1
    Affected ranges
    • ECOSYSTEM: < 1.15-1ubuntu1.14.04.1

    Update to 1.15-1ubuntu1.14.04.1

Original sources

Check your server →