p PatchFirst

CVE-2014-4966

CVE-2014-4966

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings, and does not prevent remote data with "{{" substrings, which allows remote attackers to execute arbitrary code via (1) crafted lookup('pipe') calls or (2) crafted Jinja2 data.

CVSS 9.8 · Critical · EPSS 3.5% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ansible Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.6.8+dfsg-1

    Update to 1.6.8+dfsg-1

  • ansible Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.6.8+dfsg-1

    Update to 1.6.8+dfsg-1

  • ansible Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.6.8+dfsg-1

    Update to 1.6.8+dfsg-1

  • ansible PyPI

    Versions
    • 1.0
    • 1.1
    • 1.2
    • 1.2.1
    • 1.2.2
    • 1.2.3
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.3.3
    • 1.3.4
    • 1.4
    • 1.4.1
    • 1.4.2
    • 1.4.3
    • 1.4.4
    • 1.4.5
    • 1.5
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 1.5.4
    • 1.5.5
    • 1.6
    • 1.6.1
    • 1.6.2
    • 1.6.3
    • 1.6.4
    • 1.6.5
    • 1.6.6
    Affected ranges
    • ECOSYSTEM: < 1.6.7

    Update to 1.6.7

  • ansible PyPI

    Versions
    • 1.0
    • 1.1
    • 1.2
    • 1.2.1
    • 1.2.2
    • 1.2.3
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.3.3
    • 1.3.4
    • 1.4
    • 1.4.1
    • 1.4.2
    • 1.4.3
    • 1.4.4
    • 1.4.5
    • 1.5
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 1.5.4
    • 1.5.5
    • 1.6
    • 1.6.1
    • 1.6.2
    • 1.6.3
    • 1.6.4
    • 1.6.5
    • 1.6.6
    • v1.6.6
    • v1.6.5
    • v1.6.4
    • v1.6.3
    • v1.6.2
    • v1.6.1
    • v1.6.0
    • v1.4.0
    • v1.2
    • v1.1
    • v1.0
    • 0.7
    • 0.3
    • 0.0.1
    • 0.01
    Affected ranges
    • GIT: < 62a1295a3e08cb6c3e9f1b2a1e6e5dcaeab32527
    • ECOSYSTEM: < 1.6.7

    Update to 1.6.7

  • ansible Ubuntu:Pro:14.04:LTS

    Versions
    • 1.1+dfsg-1
    • 1.3.4+dfsg-1
    • 1.4.0+dfsg-1
    • 1.4.1+dfsg-1
    • 1.4.3+dfsg-1
    • 1.4.4+dfsg-1
    • 1.5.4+dfsg-1
    • 1.5.4+dfsg-1ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: < 1.5.4+dfsg-1ubuntu0.1~esm2

    Update to 1.5.4+dfsg-1ubuntu0.1~esm2

Original sources

Check your server →