CVE-2014-5165
CVE-2014-5165
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The dissect_ber_constrained_bitstring function in epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 1.10.x before 1.10.9 does not properly validate padding values, which allows remote attackers to cause a denial of service (buffer underflow and application crash) via a crafted packet.
EPSS 2.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wireshark Debian:12
- Affected ranges
- ECOSYSTEM: < 1.12.0+git+4fab41a1-1
Update to 1.12.0+git+4fab41a1-1
wireshark Debian:13
- Affected ranges
- ECOSYSTEM: < 1.12.0+git+4fab41a1-1
Update to 1.12.0+git+4fab41a1-1
wireshark Debian:14
- Affected ranges
- ECOSYSTEM: < 1.12.0+git+4fab41a1-1
Update to 1.12.0+git+4fab41a1-1
Original sources
- https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=10187
- http://lists.opensuse.org/opensuse-updates/2014-09/msg00058.html
- http://lists.opensuse.org/opensuse-security-announce/2014-09/msg00033.html
- http://www.debian.org/security/2014/dsa-3002
- http://lists.opensuse.org/opensuse-updates/2014-08/msg00025.html
- http://www.wireshark.org/security/wnpa-sec-2014-11.html
- http://secunia.com/advisories/57593
- https://code.wireshark.org/review/gitweb?p=wireshark.git%3Ba=commit%3Bh=17a552666b50896a9b9dde8ee6a1052e7f9a622e
- https://nvd.nist.gov/vuln/detail/CVE-2014-5165