CVE-2014-5177
CVE-2014-5177
This page contains facts from public vulnerability sources. Check the original advisory before updating.
libvirt 1.0.0 through 1.2.x before 1.2.5, when fine grained access control is enabled, allows local users to read arbitrary files via a crafted XML document containing an XML external entity declaration in conjunction with an entity reference to the (1) virDomainDefineXML, (2) virNetworkCreateXML, (3) virNetworkDefineXML, (4) virStoragePoolCreateXML, (5) virStoragePoolDefineXML, (6) virStorageVolCreateXML, (7) virDomainCreateXML, (8) virNodeDeviceCreateXML, (9) virInterfaceDefineXML, (10) virStorageVolCreateXMLFrom, (11) virConnectDomainXMLFromNative, (12) virConnectDomainXMLToNative, (13) virSecretDefineXML, (14) virNWFilterDefineXML, (15) virDomainSnapshotCreateXML, (16) virDomainSaveImageDefineXML, (17) virDomainCreateXMLWithFiles, (18) virConnectCompareCPU, or (19) virConnectBaselineCPU API method, related to an XML External Entity (XXE) issue. NOTE: this issue was SPLIT from CVE-2014-0179 per ADT3 due to different affected versions of some vectors.
EPSS 0.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
libvirt Debian:12
- Affected ranges
- ECOSYSTEM: < 1.2.4-1
Update to 1.2.4-1
libvirt Debian:13
- Affected ranges
- ECOSYSTEM: < 1.2.4-1
Update to 1.2.4-1
libvirt Debian:14
- Affected ranges
- ECOSYSTEM: < 1.2.4-1
Update to 1.2.4-1
libvirt Ubuntu:14.04:LTS
- Versions
- 1.1.1-0ubuntu8
- 1.1.1-0ubuntu9
- 1.1.4-0ubuntu2
- 1.1.4-0ubuntu3
- 1.1.4-0ubuntu4
- 1.1.4-0ubuntu5
- 1.2.0-0ubuntu1
- 1.2.0-0ubuntu2
- 1.2.0-0ubuntu3
- 1.2.1-0ubuntu1
- 1.2.1-0ubuntu2
- 1.2.1-0ubuntu3
- 1.2.1-0ubuntu4
- 1.2.1-0ubuntu5
- 1.2.1-0ubuntu7
- 1.2.1-0ubuntu8
- 1.2.1-0ubuntu9
- 1.2.1-0ubuntu10
- 1.2.2-0ubuntu1
- 1.2.2-0ubuntu2
- 1.2.2-0ubuntu3
- 1.2.2-0ubuntu4
- 1.2.2-0ubuntu5
- 1.2.2-0ubuntu6
- 1.2.2-0ubuntu7
- 1.2.2-0ubuntu8
- 1.2.2-0ubuntu9
- 1.2.2-0ubuntu10
- 1.2.2-0ubuntu11
- 1.2.2-0ubuntu12
- 1.2.2-0ubuntu13
- 1.2.2-0ubuntu13.1
- 1.2.2-0ubuntu13.1.1
- 1.2.2-0ubuntu13.1.2
- 1.2.2-0ubuntu13.1.4
- Affected ranges
- ECOSYSTEM: < 1.2.2-0ubuntu13.1.5
Update to 1.2.2-0ubuntu13.1.5
Original sources
- http://rhn.redhat.com/errata/RHSA-2014-0560.html
- http://libvirt.org/news.html
- http://secunia.com/advisories/60895
- http://security.gentoo.org/glsa/glsa-201412-04.xml
- http://lists.opensuse.org/opensuse-updates/2014-05/msg00052.html
- http://lists.opensuse.org/opensuse-updates/2014-05/msg00048.html
- http://www.ubuntu.com/usn/USN-2366-1
- http://security.libvirt.org/2014/0003.html
- https://nvd.nist.gov/vuln/detail/CVE-2014-5177