p PatchFirst

CVE-2014-6272

CVE-2014-6272

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple integer overflows in the evbuffer API in Libevent 1.4.x before 1.4.15, 2.0.x before 2.0.22, and 2.1.x before 2.1.5-beta allow context-dependent attackers to cause a denial of service or possibly have other unspecified impact via "insanely large inputs" to the (1) evbuffer_add, (2) evbuffer_expand, or (3) bufferevent_write function, which triggers a heap-based buffer overflow or an infinite loop. NOTE: this identifier has been SPLIT per ADT3 due to different affected versions. See CVE-2015-6525 for the functions that are only affected in 2.0 and later.

EPSS 2.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libevent Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.0.21-stable-2

    Update to 2.0.21-stable-2

  • libevent Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.0.21-stable-2

    Update to 2.0.21-stable-2

  • libevent Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.0.21-stable-2

    Update to 2.0.21-stable-2

  • libevent Ubuntu:14.04:LTS

    Versions
    • 2.0.21-stable-1
    • 2.0.21-stable-1ubuntu1
    Affected ranges
    • ECOSYSTEM: < 2.0.21-stable-1ubuntu1.14.04.1

    Update to 2.0.21-stable-1ubuntu1.14.04.1

Original sources

Check your server →