p PatchFirst

CVE-2014-7188

CVE-2014-7188

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The hvm_msr_read_intercept function in arch/x86/hvm/hvm.c in Xen 4.1 through 4.4.x uses an improper MSR range for x2APIC emulation, which allows local HVM guests to cause a denial of service (host crash) or read data from the hypervisor or other guests via unspecified vectors.

EPSS 0.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • xen Debian:12

    Affected ranges
    • ECOSYSTEM: < 4.4.1-3

    Update to 4.4.1-3

  • xen Debian:13

    Affected ranges
    • ECOSYSTEM: < 4.4.1-3

    Update to 4.4.1-3

  • xen Debian:14

    Affected ranges
    • ECOSYSTEM: < 4.4.1-3

    Update to 4.4.1-3

  • xen Ubuntu:14.04:LTS

    Versions
    • 4.3.0-1ubuntu1
    • 4.3.0-1ubuntu2
    • 4.3.0-1ubuntu3
    • 4.3.0-1ubuntu4
    • 4.3.0-1ubuntu5
    • 4.4.0-0ubuntu3
    • 4.4.0-0ubuntu4
    • 4.4.0-0ubuntu5
    • 4.4.0-0ubuntu5.1
    Affected ranges
    • ECOSYSTEM: < 4.4.0-0ubuntu5.2

    Update to 4.4.0-0ubuntu5.2

Original sources

Check your server →