p PatchFirst

CVE-2014-7810

CVE-2014-7810

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

The Expression Language (EL) implementation in Apache Tomcat 6.x before 6.0.44, 7.x before 7.0.58, and 8.x before 8.0.16 does not properly consider the possibility of an accessible interface implemented by an inaccessible class, which allows attackers to bypass a SecurityManager protection mechanism via a web application that leverages use of incorrect privileges during EL evaluation.

EPSS 13.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • tomcat6 Ubuntu:14.04:LTS

    Versions
    • 6.0.37-1
    • 6.0.39-1
    Affected ranges
    • ECOSYSTEM: < 6.0.39-1ubuntu0.1

    Update to 6.0.39-1ubuntu0.1

  • tomcat7 Ubuntu:14.04:LTS

    Versions
    • 7.0.42-1
    • 7.0.47-1
    • 7.0.50-1
    • 7.0.52-1
    • 7.0.52-1ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 7.0.52-1ubuntu0.3

    Update to 7.0.52-1ubuntu0.3

  • tomcat6 Ubuntu:16.04:LTS

    Versions
    • 6.0.41-4
    Affected ranges
    • ECOSYSTEM: < 6.0.45+dfsg-1

    Update to 6.0.45+dfsg-1

Original sources

Check your server →